حل مشکل به روز رسانی node به نسخه جدیدتر در ionic

node js به تازگی نسخه ۱۱ رو به عنوان نسخه stable معرفی کرده است، این نسخه حاوی امکانات جدید و رفع باگ های متعدد هست و تا مدت زیادی نیز به روزرسانی خواهد شد. اما به دلایل مختلف امکان دارد نسخه هایی که از فریم ورک های مختلف تحت-نود نصب دارید هنوز به روزرسانی مربوط به نسخه ۱۱ را انتشار نداده باشند.

اگر نسخه node خود را آپدیت کرده باشید احتمالا با خطای زیر پس از اجرای پروژه آیونیک مواجه شده اید:

دلیل بروز این مشکل به روز نبودن نسخه های باینری موجود در فولدر نود ماژول شما با نسخه نودی هست که نصب کرده اید. برای رفع این خطا لازم است فقط دستور زیر را اجرا کنید تا نود-سس دوباره بیلد شود و پروژه شما آماده اجرا شود.

پیشنهاد میکنیم قبل از اینکه دست به به روز رسانی نسخه node js خود بزنید. ابتدا از کامپتیبل بودن پکیج های نصب شده با نسخه جدید اطمینان حاصل کنید. البته همیشه بازگشت به نسخه قبلی ممکن است. شما چه مشکلی با نسخه جدید node js داشتید ؟ با ما از طریق نظرات در میان بگذارید.

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *